Инструменты пользователя

Инструменты сайта

Загрузка не удалась. Возможно, проблемы с правами доступа?

linux:how-to-apt-hold

apt-get: как установить нужную версию пакета, заморозить версию пакета

Если вручную наложить заплатку на файл одного из системных пакетов и нужно, чтобы этот пакет был не обновлен (с уничтожением всех изменений) после вызова «apt-get upgrade». В этом случае пакет может быть «заморожен», в результате чего apt-get откажется его обновлять и пропустит:

# echo -e "coreutils hold" | dpkg --set-selections

ПС. coreutils - имя пакета))) Второй способ: через synaptic
Запускаем его (через sudo от рута), находим пакет. Дальше меню - Пакет - Заморозить версию.

Установить нужную версию пакета

Чтобы установить только определенную версию пакета, необходимо использовать = с именем пакета и указанием необходимой версии.

$ sudo apt-get install vsftpd=2.3.5-3ubuntu1

Посмотреть какие версии пакетов есть в наличии:

apt-cache showpkg <package name>


Посмотреть доступные версии пакета в репозитории можно командой:

aptitude versions <package name>


Узнать имеющиеся в кеше предыдущие версии можно командой (для Ubuntu)

ls -l  /var/cache/apt/archives/ | grep <package name>
linux/how-to-apt-hold.txt · Последние изменения: 2018/01/14 09:39 (внешнее изменение)